{
  "info": {
    "_postman_id": "68eec21c-d3ca-4072-8d88-5424eb014276",
    "name": "RingCentral Adaptive Cards OAuth 2.0 / OpenID Connect API",
    "description": "RingCentral API specification\n\nContact Support:\n Name: RingCentral Developers Support",
    "schema": "https://schema.getpostman.com/json/collection/v2.1.0/collection.json",
    "createdAt": "2026-07-28T02:50:23.000Z",
    "updatedAt": "2026-07-28T02:50:23.000Z",
    "lastUpdatedBy": "35240",
    "uid": "35240-68eec21c-d3ca-4072-8d88-5424eb014276"
  },
  "item": [
    {
      "name": "restapi",
      "item": [
        {
          "name": "oauth",
          "item": [
            {
              "name": "token",
              "item": [
                {
                  "name": "OAuth 2.0 Token Endpoint",
                  "id": "625acfd1-f892-4c20-87c4-7fd7b136cf89",
                  "protocolProfileBehavior": {
                    "disableBodyPruning": true
                  },
                  "request": {
                    "auth": {
                      "type": "noauth"
                    },
                    "method": "POST",
                    "header": [
                      {
                        "key": "Content-Type",
                        "value": "application/x-www-form-urlencoded"
                      },
                      {
                        "key": "Accept",
                        "value": "application/json"
                      }
                    ],
                    "body": {
                      "mode": "urlencoded",
                      "urlencoded": [
                        {
                          "description": "(Required) Grant type",
                          "key": "grant_type",
                          "value": "guest"
                        },
                        {
                          "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                          "key": "client_assertion_type",
                          "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                        },
                        {
                          "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                          "key": "client_assertion",
                          "value": "<string>"
                        },
                        {
                          "description": "The list of application permissions (OAuth scopes) requested.\nBy default, it includes all permissions configured on\nthe client application registration\n",
                          "key": "scope",
                          "value": "<string>"
                        },
                        {
                          "description": "The registered identifier of a client application.\nUsed to identify a client ONLY if the client authentication is not required and\ncorresponding credentials are not provided with this request\n",
                          "key": "client_id",
                          "value": "<string>"
                        },
                        {
                          "description": "The unique identifier of a client application instance. If not\nspecified, the derived or auto-generated value will be used\n",
                          "key": "endpoint_id",
                          "value": "<string>"
                        },
                        {
                          "description": "Access token lifetime in seconds",
                          "key": "access_token_ttl",
                          "value": "3600"
                        },
                        {
                          "description": "Refresh token lifetime in seconds",
                          "key": "refresh_token_ttl",
                          "value": "604800"
                        },
                        {
                          "description": "For `authorization_code` grant type only. User's authorization code",
                          "key": "code",
                          "value": "<string>"
                        },
                        {
                          "description": "For `authorization_code` grant type only. This is a callback URI which determines where the response\nis sent. The value of this parameter must exactly match one of\nthe URIs you have provided for your app upon registration\n",
                          "key": "redirect_uri",
                          "value": "<uri>"
                        },
                        {
                          "description": "For `authorization_code` grant type only.\nThe code verifier as defined by  the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                          "key": "code_verifier",
                          "value": "<string>"
                        }
                      ]
                    },
                    "url": {
                      "raw": "{{baseUrl}}/restapi/oauth/token",
                      "host": [
                        "{{baseUrl}}"
                      ],
                      "path": [
                        "restapi",
                        "oauth",
                        "token"
                      ]
                    },
                    "description": "Returns access (and potentially refresh) tokens for making API requests.\n\nFor confidential client application types\nthis endpoint requires client authentication using one of the supported\nmethods (`client_secret_basic`, `client_secret_jwt` or `private_key_jwt`)\n\nFor non-confidential client application types\nthe client identifier must be provided via `client_id` request attribute.\n"
                  },
                  "response": [
                    {
                      "id": "2921baa5-6e83-41bc-a04d-67187922fbc5",
                      "name": "Access/Refresh Tokens",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          },
                          {
                            "key": "Accept",
                            "value": "application/json"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Grant type",
                              "key": "grant_type",
                              "value": "guest"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of application permissions (OAuth scopes) requested.\nBy default, it includes all permissions configured on\nthe client application registration\n",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "The registered identifier of a client application.\nUsed to identify a client ONLY if the client authentication is not required and\ncorresponding credentials are not provided with this request\n",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "The unique identifier of a client application instance. If not\nspecified, the derived or auto-generated value will be used\n",
                              "key": "endpoint_id",
                              "value": "<string>"
                            },
                            {
                              "description": "Access token lifetime in seconds",
                              "key": "access_token_ttl",
                              "value": "3600"
                            },
                            {
                              "description": "Refresh token lifetime in seconds",
                              "key": "refresh_token_ttl",
                              "value": "604800"
                            },
                            {
                              "description": "For `authorization_code` grant type only. User's authorization code",
                              "key": "code",
                              "value": "<string>"
                            },
                            {
                              "description": "For `authorization_code` grant type only. This is a callback URI which determines where the response\nis sent. The value of this parameter must exactly match one of\nthe URIs you have provided for your app upon registration\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "For `authorization_code` grant type only.\nThe code verifier as defined by  the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_verifier",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/token",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "token"
                          ]
                        }
                      },
                      "status": "OK",
                      "code": 200,
                      "_postman_previewlanguage": "json",
                      "header": [
                        {
                          "key": "Content-Type",
                          "value": "application/json"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": "{\n  \"access_token\": \"<string>\",\n  \"expires_in\": \"<integer>\",\n  \"scope\": \"<string>\",\n  \"token_type\": \"bearer\",\n  \"refresh_token\": \"<string>\",\n  \"refresh_token_expires_in\": \"<integer>\",\n  \"owner_id\": \"<string>\",\n  \"endpoint_id\": \"<string>\",\n  \"id_token\": \"<string>\",\n  \"session_expires_in\": \"<integer>\",\n  \"session_expiration_time\": \"<dateTime>\",\n  \"session_id\": \"<string>\",\n  \"session_idle_timeout\": \"<integer>\"\n}",
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-2921baa5-6e83-41bc-a04d-67187922fbc5"
                    },
                    {
                      "id": "0c2bdfa0-b08f-41ee-8f7c-0f0071cd0eb4",
                      "name": "The response with **HTTP 400 \"Bad request\"** status used in some OAuth / OpenID Connect endpoints.\n",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          },
                          {
                            "key": "Accept",
                            "value": "application/json"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Grant type",
                              "key": "grant_type",
                              "value": "guest"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of application permissions (OAuth scopes) requested.\nBy default, it includes all permissions configured on\nthe client application registration\n",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "The registered identifier of a client application.\nUsed to identify a client ONLY if the client authentication is not required and\ncorresponding credentials are not provided with this request\n",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "The unique identifier of a client application instance. If not\nspecified, the derived or auto-generated value will be used\n",
                              "key": "endpoint_id",
                              "value": "<string>"
                            },
                            {
                              "description": "Access token lifetime in seconds",
                              "key": "access_token_ttl",
                              "value": "3600"
                            },
                            {
                              "description": "Refresh token lifetime in seconds",
                              "key": "refresh_token_ttl",
                              "value": "604800"
                            },
                            {
                              "description": "For `authorization_code` grant type only. User's authorization code",
                              "key": "code",
                              "value": "<string>"
                            },
                            {
                              "description": "For `authorization_code` grant type only. This is a callback URI which determines where the response\nis sent. The value of this parameter must exactly match one of\nthe URIs you have provided for your app upon registration\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "For `authorization_code` grant type only.\nThe code verifier as defined by  the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_verifier",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/token",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "token"
                          ]
                        }
                      },
                      "status": "Bad Request",
                      "code": 400,
                      "_postman_previewlanguage": "json",
                      "header": [
                        {
                          "key": "Content-Type",
                          "value": "application/json"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": "{\n  \"errors\": [\n    {\n      \"errorCode\": \"<string>\",\n      \"message\": \"<string>\",\n      \"parameterName\": \"<string>\",\n      \"parameterValue\": \"<string>\"\n    }\n  ],\n  \"error\": \"invalid_grant\"\n}",
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-0c2bdfa0-b08f-41ee-8f7c-0f0071cd0eb4"
                    },
                    {
                      "id": "0cd355df-6e8e-4b17-aa9b-9ae9ead99ea8",
                      "name": "Unsupported Media Type",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Grant type",
                              "key": "grant_type",
                              "value": "guest"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of application permissions (OAuth scopes) requested.\nBy default, it includes all permissions configured on\nthe client application registration\n",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "The registered identifier of a client application.\nUsed to identify a client ONLY if the client authentication is not required and\ncorresponding credentials are not provided with this request\n",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "The unique identifier of a client application instance. If not\nspecified, the derived or auto-generated value will be used\n",
                              "key": "endpoint_id",
                              "value": "<string>"
                            },
                            {
                              "description": "Access token lifetime in seconds",
                              "key": "access_token_ttl",
                              "value": "3600"
                            },
                            {
                              "description": "Refresh token lifetime in seconds",
                              "key": "refresh_token_ttl",
                              "value": "604800"
                            },
                            {
                              "description": "For `authorization_code` grant type only. User's authorization code",
                              "key": "code",
                              "value": "<string>"
                            },
                            {
                              "description": "For `authorization_code` grant type only. This is a callback URI which determines where the response\nis sent. The value of this parameter must exactly match one of\nthe URIs you have provided for your app upon registration\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "For `authorization_code` grant type only.\nThe code verifier as defined by  the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_verifier",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/token",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "token"
                          ]
                        }
                      },
                      "status": "Unsupported Media Type",
                      "code": 415,
                      "_postman_previewlanguage": "text",
                      "header": [],
                      "cookie": [],
                      "responseTime": null,
                      "body": null,
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-0cd355df-6e8e-4b17-aa9b-9ae9ead99ea8"
                    },
                    {
                      "id": "1e8de7c6-2aa2-4a81-82a0-6ca0ef92d4c5",
                      "name": "Request rate exceeded",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Grant type",
                              "key": "grant_type",
                              "value": "guest"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of application permissions (OAuth scopes) requested.\nBy default, it includes all permissions configured on\nthe client application registration\n",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "The registered identifier of a client application.\nUsed to identify a client ONLY if the client authentication is not required and\ncorresponding credentials are not provided with this request\n",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "The unique identifier of a client application instance. If not\nspecified, the derived or auto-generated value will be used\n",
                              "key": "endpoint_id",
                              "value": "<string>"
                            },
                            {
                              "description": "Access token lifetime in seconds",
                              "key": "access_token_ttl",
                              "value": "3600"
                            },
                            {
                              "description": "Refresh token lifetime in seconds",
                              "key": "refresh_token_ttl",
                              "value": "604800"
                            },
                            {
                              "description": "For `authorization_code` grant type only. User's authorization code",
                              "key": "code",
                              "value": "<string>"
                            },
                            {
                              "description": "For `authorization_code` grant type only. This is a callback URI which determines where the response\nis sent. The value of this parameter must exactly match one of\nthe URIs you have provided for your app upon registration\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "For `authorization_code` grant type only.\nThe code verifier as defined by  the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_verifier",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/token",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "token"
                          ]
                        }
                      },
                      "status": "Too Many Requests",
                      "code": 429,
                      "_postman_previewlanguage": "text",
                      "header": [],
                      "cookie": [],
                      "responseTime": null,
                      "body": null,
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-1e8de7c6-2aa2-4a81-82a0-6ca0ef92d4c5"
                    }
                  ],
                  "createdAt": "2026-07-28T02:50:23.000Z",
                  "updatedAt": "2026-07-28T02:50:23.000Z",
                  "uid": "35240-625acfd1-f892-4c20-87c4-7fd7b136cf89"
                }
              ],
              "id": "f4fad5c3-ceac-46a8-ac71-718b42e0efda",
              "createdAt": "2026-07-28T02:50:23.000Z",
              "updatedAt": "2026-07-28T02:50:23.000Z",
              "uid": "35240-f4fad5c3-ceac-46a8-ac71-718b42e0efda"
            },
            {
              "name": "authorize",
              "item": [
                {
                  "name": "OAuth 2.0 Authorization Endpoint",
                  "id": "7a793c50-f69a-4bbc-9e23-51f2de53023b",
                  "protocolProfileBehavior": {
                    "disableBodyPruning": true
                  },
                  "request": {
                    "method": "GET",
                    "header": [
                      {
                        "key": "Accept",
                        "value": "application/json"
                      }
                    ],
                    "url": {
                      "raw": "{{baseUrl}}/restapi/oauth/authorize?client_id=<string>&response_type=code&redirect_uri=<uri>&state=<string>&scope=<string>&display=page&prompt=login sso&ui_locales=<string>&localeId=<string>&code_challenge=<string>&code_challenge_method=plain&nonce=<string>&ui_options=<string>&login_hint=<string>&brand_id=<string>",
                      "host": [
                        "{{baseUrl}}"
                      ],
                      "path": [
                        "restapi",
                        "oauth",
                        "authorize"
                      ],
                      "query": [
                        {
                          "description": "(Required) The registered identifier of a client application",
                          "key": "client_id",
                          "value": "<string>"
                        },
                        {
                          "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                          "key": "response_type",
                          "value": "code"
                        },
                        {
                          "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                          "key": "redirect_uri",
                          "value": "<uri>"
                        },
                        {
                          "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                          "key": "state",
                          "value": "<string>"
                        },
                        {
                          "description": "The list of space separated application permissions (OAuth scopes)",
                          "key": "scope",
                          "value": "<string>"
                        },
                        {
                          "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                          "key": "display",
                          "value": "page"
                        },
                        {
                          "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                          "key": "prompt",
                          "value": "login sso"
                        },
                        {
                          "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                          "key": "ui_locales",
                          "value": "<string>"
                        },
                        {
                          "description": "DEPRECATED: `ui_locales` parameter should be used instead",
                          "key": "localeId",
                          "value": "<string>"
                        },
                        {
                          "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                          "key": "code_challenge",
                          "value": "<string>"
                        },
                        {
                          "description": "The code challenge method as defined by by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                          "key": "code_challenge_method",
                          "value": "plain"
                        },
                        {
                          "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                          "key": "nonce",
                          "value": "<string>"
                        },
                        {
                          "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                          "key": "ui_options",
                          "value": "<string>"
                        },
                        {
                          "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                          "key": "login_hint",
                          "value": "<string>"
                        },
                        {
                          "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                          "key": "brand_id",
                          "value": "<string>"
                        }
                      ]
                    },
                    "description": "Performs Authentication of the End-User by sending the User Agent to the Authorization Server's\nAuthorization Endpoint for Authentication and Authorization,\nusing request parameters defined by OAuth 2.0 [RFC-6749](https://datatracker.ietf.org/doc/html/rfc6749#section-3.1)\nand additional parameters and parameter values defined by\n[OpenID Connect Core 1.0](https://openid.net/specs/openid-connect-core-1_0.html#AuthorizationEndpoint).\n\nThis is the version that uses HTTP `GET` method.\n"
                  },
                  "response": [
                    {
                      "id": "6faa4e89-453e-4205-aef7-0cc7b39640be",
                      "name": "Successful response, HTTP redirect to login form",
                      "originalRequest": {
                        "method": "GET",
                        "header": [
                          {
                            "description": "Added as a part of security scheme: oauth2",
                            "key": "Authorization",
                            "value": "<token>"
                          }
                        ],
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/authorize?client_id=<string>&response_type=code&redirect_uri=<uri>&state=<string>&scope=<string>&display=page&prompt=login sso&ui_locales=<string>&localeId=<string>&code_challenge=<string>&code_challenge_method=plain&nonce=<string>&ui_options=<string>&login_hint=<string>&brand_id=<string>",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "authorize"
                          ],
                          "query": [
                            {
                              "description": "(Required) The registered identifier of a client application",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                              "key": "response_type",
                              "value": "code"
                            },
                            {
                              "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                              "key": "state",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of space separated application permissions (OAuth scopes)",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                              "key": "display",
                              "value": "page"
                            },
                            {
                              "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                              "key": "prompt",
                              "value": "login sso"
                            },
                            {
                              "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                              "key": "ui_locales",
                              "value": "<string>"
                            },
                            {
                              "description": "DEPRECATED: `ui_locales` parameter should be used instead",
                              "key": "localeId",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge method as defined by by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge_method",
                              "value": "plain"
                            },
                            {
                              "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                              "key": "nonce",
                              "value": "<string>"
                            },
                            {
                              "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                              "key": "ui_options",
                              "value": "<string>"
                            },
                            {
                              "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                              "key": "login_hint",
                              "value": "<string>"
                            },
                            {
                              "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                              "key": "brand_id",
                              "value": "<string>"
                            }
                          ]
                        }
                      },
                      "status": "Found",
                      "code": 302,
                      "_postman_previewlanguage": "text",
                      "header": [
                        {
                          "disabled": false,
                          "description": {
                            "content": "Full URL of the redirect target locations",
                            "type": "text/plain"
                          },
                          "key": "Location",
                          "value": "<uri>"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": null,
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-6faa4e89-453e-4205-aef7-0cc7b39640be"
                    },
                    {
                      "id": "2b30738c-7a69-4ca1-aeeb-55c5cca62f65",
                      "name": "The response with **HTTP 400 \"Bad request\"** status used in some OAuth / OpenID Connect endpoints.\n",
                      "originalRequest": {
                        "method": "GET",
                        "header": [
                          {
                            "key": "Accept",
                            "value": "application/json"
                          },
                          {
                            "description": "Added as a part of security scheme: oauth2",
                            "key": "Authorization",
                            "value": "<token>"
                          }
                        ],
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/authorize?client_id=<string>&response_type=code&redirect_uri=<uri>&state=<string>&scope=<string>&display=page&prompt=login sso&ui_locales=<string>&localeId=<string>&code_challenge=<string>&code_challenge_method=plain&nonce=<string>&ui_options=<string>&login_hint=<string>&brand_id=<string>",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "authorize"
                          ],
                          "query": [
                            {
                              "description": "(Required) The registered identifier of a client application",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                              "key": "response_type",
                              "value": "code"
                            },
                            {
                              "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                              "key": "state",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of space separated application permissions (OAuth scopes)",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                              "key": "display",
                              "value": "page"
                            },
                            {
                              "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                              "key": "prompt",
                              "value": "login sso"
                            },
                            {
                              "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                              "key": "ui_locales",
                              "value": "<string>"
                            },
                            {
                              "description": "DEPRECATED: `ui_locales` parameter should be used instead",
                              "key": "localeId",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge method as defined by by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge_method",
                              "value": "plain"
                            },
                            {
                              "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                              "key": "nonce",
                              "value": "<string>"
                            },
                            {
                              "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                              "key": "ui_options",
                              "value": "<string>"
                            },
                            {
                              "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                              "key": "login_hint",
                              "value": "<string>"
                            },
                            {
                              "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                              "key": "brand_id",
                              "value": "<string>"
                            }
                          ]
                        }
                      },
                      "status": "Bad Request",
                      "code": 400,
                      "_postman_previewlanguage": "json",
                      "header": [
                        {
                          "key": "Content-Type",
                          "value": "application/json"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": "{\n  \"errors\": [\n    {\n      \"errorCode\": \"<string>\",\n      \"message\": \"<string>\",\n      \"parameterName\": \"<string>\",\n      \"parameterValue\": \"<string>\"\n    }\n  ],\n  \"error\": \"invalid_grant\"\n}",
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-2b30738c-7a69-4ca1-aeeb-55c5cca62f65"
                    }
                  ],
                  "createdAt": "2026-07-28T02:50:23.000Z",
                  "updatedAt": "2026-07-28T02:50:23.000Z",
                  "uid": "35240-7a793c50-f69a-4bbc-9e23-51f2de53023b"
                },
                {
                  "name": "OAuth 2.0 Authorization Endpoint (POST)",
                  "id": "ea46f432-7b5e-4983-be57-b4999ab71722",
                  "protocolProfileBehavior": {
                    "disableBodyPruning": true
                  },
                  "request": {
                    "method": "POST",
                    "header": [
                      {
                        "key": "Content-Type",
                        "value": "application/x-www-form-urlencoded"
                      },
                      {
                        "key": "Accept",
                        "value": "application/json"
                      }
                    ],
                    "body": {
                      "mode": "urlencoded",
                      "urlencoded": [
                        {
                          "description": "(Required) The registered identifier of a client application",
                          "key": "client_id",
                          "value": "<string>"
                        },
                        {
                          "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                          "key": "response_type",
                          "value": "code"
                        },
                        {
                          "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                          "key": "redirect_uri",
                          "value": "<uri>"
                        },
                        {
                          "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                          "key": "state",
                          "value": "<string>"
                        },
                        {
                          "description": "The list of requested OAuth scopes (space separated)",
                          "key": "scope",
                          "value": "<string>"
                        },
                        {
                          "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                          "key": "display",
                          "value": "page"
                        },
                        {
                          "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                          "key": "prompt",
                          "value": "login sso"
                        },
                        {
                          "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                          "key": "ui_locales",
                          "value": "<string>"
                        },
                        {
                          "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                          "key": "code_challenge",
                          "value": "<string>"
                        },
                        {
                          "description": "The code challenge method as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                          "key": "code_challenge_method",
                          "value": "plain"
                        },
                        {
                          "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                          "key": "nonce",
                          "value": "<string>"
                        },
                        {
                          "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                          "key": "ui_options",
                          "value": "<string>"
                        },
                        {
                          "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                          "key": "login_hint",
                          "value": "<string>"
                        },
                        {
                          "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                          "key": "brand_id",
                          "value": "<string>"
                        },
                        {
                          "key": "accept_language",
                          "value": "<string>"
                        }
                      ]
                    },
                    "url": {
                      "raw": "{{baseUrl}}/restapi/oauth/authorize",
                      "host": [
                        "{{baseUrl}}"
                      ],
                      "path": [
                        "restapi",
                        "oauth",
                        "authorize"
                      ]
                    },
                    "description": "Performs Authentication of the End-User by sending the User Agent to the Authorization Server's\nAuthorization Endpoint for Authentication and Authorization,\nusing request parameters defined by OAuth 2.0 [RFC-6749](https://datatracker.ietf.org/doc/html/rfc6749#section-3.1)\nand additional parameters and parameter values defined by\n[OpenID Connect Core 1.0](https://openid.net/specs/openid-connect-core-1_0.html#AuthorizationEndpoint).\n\nThis is the version that uses HTTP `POST` method.\n"
                  },
                  "response": [
                    {
                      "id": "d8e39fb6-09ae-495f-bcf5-48c2733d99bf",
                      "name": "Successful response, HTTP redirect to login form",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          },
                          {
                            "description": "Added as a part of security scheme: oauth2",
                            "key": "Authorization",
                            "value": "<token>"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) The registered identifier of a client application",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                              "key": "response_type",
                              "value": "code"
                            },
                            {
                              "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                              "key": "state",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of requested OAuth scopes (space separated)",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                              "key": "display",
                              "value": "page"
                            },
                            {
                              "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                              "key": "prompt",
                              "value": "login sso"
                            },
                            {
                              "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                              "key": "ui_locales",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge method as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge_method",
                              "value": "plain"
                            },
                            {
                              "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                              "key": "nonce",
                              "value": "<string>"
                            },
                            {
                              "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                              "key": "ui_options",
                              "value": "<string>"
                            },
                            {
                              "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                              "key": "login_hint",
                              "value": "<string>"
                            },
                            {
                              "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                              "key": "brand_id",
                              "value": "<string>"
                            },
                            {
                              "key": "accept_language",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/authorize",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "authorize"
                          ]
                        }
                      },
                      "status": "Found",
                      "code": 302,
                      "_postman_previewlanguage": "text",
                      "header": [
                        {
                          "disabled": false,
                          "description": {
                            "content": "Full URL of the redirect target locations",
                            "type": "text/plain"
                          },
                          "key": "Location",
                          "value": "<uri>"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": null,
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-d8e39fb6-09ae-495f-bcf5-48c2733d99bf"
                    },
                    {
                      "id": "ab7652e5-a953-4e5e-80dc-f05d5303165c",
                      "name": "The response with **HTTP 400 \"Bad request\"** status used in some OAuth / OpenID Connect endpoints.\n",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          },
                          {
                            "key": "Accept",
                            "value": "application/json"
                          },
                          {
                            "description": "Added as a part of security scheme: oauth2",
                            "key": "Authorization",
                            "value": "<token>"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) The registered identifier of a client application",
                              "key": "client_id",
                              "value": "<string>"
                            },
                            {
                              "description": "(Required) Determines authorization flow type. The only supported value is `code` which corresponds to OAuth 2.0 \"Authorization Code Flow\"\n",
                              "key": "response_type",
                              "value": "code"
                            },
                            {
                              "description": "This is the URI where the Authorization Server redirects the User Agent to at the end of the authorization flow.\nThe value of this parameter must exactly match one of the URIs registered for this client application.\nThis parameter is required if there are more than one redirect URIs registered for the app.\n",
                              "key": "redirect_uri",
                              "value": "<uri>"
                            },
                            {
                              "description": "An opaque value used by the client to maintain state between the request and callback.\nThe authorization server includes this value when redirecting the User Agent back\nto the client. The parameter SHOULD be used for preventing cross-site request forgery attacks.\n",
                              "key": "state",
                              "value": "<string>"
                            },
                            {
                              "description": "The list of requested OAuth scopes (space separated)",
                              "key": "scope",
                              "value": "<string>"
                            },
                            {
                              "description": "Specifies how the Authorization Server displays the authentication and consent user interface pages to the End-User.\n",
                              "key": "display",
                              "value": "page"
                            },
                            {
                              "description": "Space-delimited, case-sensitive list of ASCII string values that specifies whether the Authorization Server prompts the End-User for\nre-authentication and consent. The defined values are:\n\n- `login` - RingCentral native login form,\n- `sso` - Single Sign-On login form,\n- `consent` - form to show the requested scope and prompt user for consent.\n\nEither `login` or `sso` (or both) must be specified. The default\nvalue is `login sso`\n",
                              "key": "prompt",
                              "value": "login sso"
                            },
                            {
                              "description": "End-User's preferred languages and scripts for the user interface, represented as a space-separated list of\n[RFC-5646](https://datatracker.ietf.org/doc/html/rfc5646) language tag values, ordered by preference.\n\nIf this parameter is provided, its value overrides 'Accept-Language' header value and 'localeId' parameter value (if any)\n",
                              "key": "ui_locales",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge value as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge",
                              "value": "<string>"
                            },
                            {
                              "description": "The code challenge method as defined by the PKCE specification -\n[RFC-7636 \"Proof Key for Code Exchange by OAuth Public Clients\"](https://datatracker.ietf.org/doc/html/rfc7636)\n",
                              "key": "code_challenge_method",
                              "value": "plain"
                            },
                            {
                              "description": "String value used to associate a Client session with an ID Token, and to mitigate replay attacks. The value is passed through unmodified from the Authentication Request to the ID Token.\n",
                              "key": "nonce",
                              "value": "<string>"
                            },
                            {
                              "description": "Login form user interface options (space-separated). By default, the UI options that are registered for this client application will be used\n",
                              "key": "ui_options",
                              "value": "<string>"
                            },
                            {
                              "description": "Hint to the Authorization Server about the login identifier the End-User might use to log in.",
                              "key": "login_hint",
                              "value": "<string>"
                            },
                            {
                              "description": "RingCentral Brand identifier. If it is not provided in the request,\nserver will try to determine brand from the client application profile.\n",
                              "key": "brand_id",
                              "value": "<string>"
                            },
                            {
                              "key": "accept_language",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/authorize",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "authorize"
                          ]
                        }
                      },
                      "status": "Bad Request",
                      "code": 400,
                      "_postman_previewlanguage": "json",
                      "header": [
                        {
                          "key": "Content-Type",
                          "value": "application/json"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": "{\n  \"errors\": [\n    {\n      \"errorCode\": \"<string>\",\n      \"message\": \"<string>\",\n      \"parameterName\": \"<string>\",\n      \"parameterValue\": \"<string>\"\n    }\n  ],\n  \"error\": \"invalid_grant\"\n}",
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-ab7652e5-a953-4e5e-80dc-f05d5303165c"
                    }
                  ],
                  "createdAt": "2026-07-28T02:50:23.000Z",
                  "updatedAt": "2026-07-28T02:50:23.000Z",
                  "uid": "35240-ea46f432-7b5e-4983-be57-b4999ab71722"
                }
              ],
              "id": "69432779-6be8-4657-bac9-20c51b331d2d",
              "createdAt": "2026-07-28T02:50:23.000Z",
              "updatedAt": "2026-07-28T02:50:23.000Z",
              "uid": "35240-69432779-6be8-4657-bac9-20c51b331d2d"
            },
            {
              "name": "revoke",
              "item": [
                {
                  "name": "OAuth 2.0 Token Revocation Endpoint",
                  "id": "f6eea991-2397-40f1-b601-bae2480ce338",
                  "protocolProfileBehavior": {
                    "disableBodyPruning": true
                  },
                  "request": {
                    "auth": {
                      "type": "noauth"
                    },
                    "method": "POST",
                    "header": [
                      {
                        "key": "Content-Type",
                        "value": "application/x-www-form-urlencoded"
                      },
                      {
                        "key": "Accept",
                        "value": "application/json"
                      }
                    ],
                    "body": {
                      "mode": "urlencoded",
                      "urlencoded": [
                        {
                          "description": "(Required) Access or refresh token to be revoked (along with the entire OAuth session)",
                          "key": "token",
                          "value": "<string>"
                        },
                        {
                          "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                          "key": "client_assertion_type",
                          "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                        },
                        {
                          "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                          "key": "client_assertion",
                          "value": "<string>"
                        }
                      ]
                    },
                    "url": {
                      "raw": "{{baseUrl}}/restapi/oauth/revoke?token=<string>",
                      "host": [
                        "{{baseUrl}}"
                      ],
                      "path": [
                        "restapi",
                        "oauth",
                        "revoke"
                      ],
                      "query": [
                        {
                          "description": "Access or refresh token to be revoked (along with the entire OAuth session)",
                          "key": "token",
                          "value": "<string>"
                        }
                      ]
                    },
                    "description": "Revokes all active access/refresh tokens and invalidates the OAuth session basing on token provided.\nThe `token` parameter may be passed in query string or body and may represent access or refresh token.\n\nThis endpoint is defined by [RFC-7009 \"OAuth 2.0 Token Revocation\"](https://datatracker.ietf.org/doc/html/rfc7009)\n\nFor confidential client application types\nthis endpoint requires client authentication using one of the supported\nmethods (`client_secret_basic`, `client_secret_jwt` or `private_key_jwt`)\n"
                  },
                  "response": [
                    {
                      "id": "8b013f83-8e6a-43f2-a807-5796e82f9d1c",
                      "name": "Successful response",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Access or refresh token to be revoked (along with the entire OAuth session)",
                              "key": "token",
                              "value": "<string>"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/revoke?token=<string>",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "revoke"
                          ],
                          "query": [
                            {
                              "description": "Access or refresh token to be revoked (along with the entire OAuth session)",
                              "key": "token",
                              "value": "<string>"
                            }
                          ]
                        }
                      },
                      "status": "OK",
                      "code": 200,
                      "_postman_previewlanguage": "text",
                      "header": [],
                      "cookie": [],
                      "responseTime": null,
                      "body": null,
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-8b013f83-8e6a-43f2-a807-5796e82f9d1c"
                    },
                    {
                      "id": "2e8950a9-d144-4173-b2da-a811318c6c8f",
                      "name": "The response with **HTTP 400 \"Bad request\"** status used in some OAuth / OpenID Connect endpoints.\n",
                      "originalRequest": {
                        "method": "POST",
                        "header": [
                          {
                            "key": "Content-Type",
                            "value": "application/x-www-form-urlencoded"
                          },
                          {
                            "key": "Accept",
                            "value": "application/json"
                          }
                        ],
                        "body": {
                          "mode": "urlencoded",
                          "urlencoded": [
                            {
                              "description": "(Required) Access or refresh token to be revoked (along with the entire OAuth session)",
                              "key": "token",
                              "value": "<string>"
                            },
                            {
                              "description": "Client assertion type for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion_type",
                              "value": "urn:ietf:params:oauth:client-assertion-type:jwt-bearer"
                            },
                            {
                              "description": "Client assertion (JWT) for the `client_secret_jwt` or `private_key_jwt` client authentication types,\nas defined by [RFC-7523](https://datatracker.ietf.org/doc/html/rfc7523#section-2.2).\nThis parameter is mandatory if the client authentication is required and a client decided to use one of these authentication types\n",
                              "key": "client_assertion",
                              "value": "<string>"
                            }
                          ]
                        },
                        "url": {
                          "raw": "{{baseUrl}}/restapi/oauth/revoke?token=<string>",
                          "host": [
                            "{{baseUrl}}"
                          ],
                          "path": [
                            "restapi",
                            "oauth",
                            "revoke"
                          ],
                          "query": [
                            {
                              "description": "Access or refresh token to be revoked (along with the entire OAuth session)",
                              "key": "token",
                              "value": "<string>"
                            }
                          ]
                        }
                      },
                      "status": "Bad Request",
                      "code": 400,
                      "_postman_previewlanguage": "json",
                      "header": [
                        {
                          "key": "Content-Type",
                          "value": "application/json"
                        }
                      ],
                      "cookie": [],
                      "responseTime": null,
                      "body": "{\n  \"errors\": [\n    {\n      \"errorCode\": \"<string>\",\n      \"message\": \"<string>\",\n      \"parameterName\": \"<string>\",\n      \"parameterValue\": \"<string>\"\n    }\n  ],\n  \"error\": \"invalid_grant\"\n}",
                      "createdAt": "2026-07-28T02:50:23.000Z",
                      "updatedAt": "2026-07-28T02:50:23.000Z",
                      "uid": "35240-2e8950a9-d144-4173-b2da-a811318c6c8f"
                    }
                  ],
                  "createdAt": "2026-07-28T02:50:23.000Z",
                  "updatedAt": "2026-07-28T02:50:23.000Z",
                  "uid": "35240-f6eea991-2397-40f1-b601-bae2480ce338"
                }
              ],
              "id": "b1d0f9a4-752d-42a9-bf07-c379e949fe32",
              "createdAt": "2026-07-28T02:50:23.000Z",
              "updatedAt": "2026-07-28T02:50:23.000Z",
              "uid": "35240-b1d0f9a4-752d-42a9-bf07-c379e949fe32"
            }
          ],
          "id": "403b9a12-8370-45ea-9d8b-4c06180e9d4e",
          "createdAt": "2026-07-28T02:50:23.000Z",
          "updatedAt": "2026-07-28T02:50:23.000Z",
          "uid": "35240-403b9a12-8370-45ea-9d8b-4c06180e9d4e"
        }
      ],
      "id": "13587596-bb44-4045-b94e-53aa6a5cacd9",
      "createdAt": "2026-07-28T02:50:23.000Z",
      "updatedAt": "2026-07-28T02:50:23.000Z",
      "uid": "35240-13587596-bb44-4045-b94e-53aa6a5cacd9"
    }
  ],
  "auth": {
    "type": "oauth2",
    "oauth2": [
      {
        "key": "redirect_uri",
        "value": "https://platform.ringcentral.com/restapi/oauth/token",
        "type": "string"
      },
      {
        "key": "accessTokenUrl",
        "value": "https://platform.ringcentral.com/restapi/oauth/token",
        "type": "string"
      },
      {
        "key": "authUrl",
        "value": "https://platform.ringcentral.com/restapi/oauth/authorize",
        "type": "string"
      },
      {
        "key": "grant_type",
        "value": "authorization_code",
        "type": "string"
      }
    ]
  },
  "variable": [
    {
      "key": "baseUrl",
      "value": "https://platform.ringcentral.com"
    }
  ]
}